We are investigating

Minor incident Business Email
14-June-2023 11:43 AM +04 · 33 minutes

Updates

Resolved

We are writing to inform you that the incident that was reported has been resolved. We apologize for any inconvenience this may have caused and thank you for bringing it to our attention.

We understand the importance of timely and efficient resolution of any incidents and we are glad that we were able to resolve this one for you in a timely manner. We have also taken steps to ensure that similar incidents do not occur in the future.

If you have any further concerns or issues, please do not hesitate to contact us.

Thank you for your patience and understanding.

June 14, 2023 · 12:15 PM +04
Investigating

We have detected issue with business email server cluster and we are currently investigating it, we’ll update you soon.

June 14, 2023 · 11:43 AM +04

← Back